Arbitrary Code Injection Affecting spamassassin package, versions <3.4.2-0ubuntu0.18.04.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.98% (61st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-SPAMASSASSIN-275490
  • published25 Sept 2018
  • disclosed17 Sept 2018

Introduced: 17 Sep 2018

CVE-2018-11781  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 spamassassin to version 3.4.2-0ubuntu0.18.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream spamassassin package and not the spamassassin package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Apache SpamAssassin 3.4.2 fixes a local user code injection in the meta rule syntax.