Missing Initialization of Resource Affecting strongswan package, versions <5.6.2-1ubuntu2.2


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
6.2% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-STRONGSWAN-385082
  • published19 Jun 2018
  • disclosed19 Jun 2018

Introduced: 19 Jun 2018

CVE-2018-10811  (opens in a new tab)
CWE-909  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 strongswan to version 5.6.2-1ubuntu2.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream strongswan package and not the strongswan package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

strongSwan 5.6.0 and older allows Remote Denial of Service because of Missing Initialization of a Variable.

CVSS Base Scores

version 3.1