Improper Authentication Affecting symfony package, versions <3.4.6+dfsg-1ubuntu0.1+esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.37% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-SYMFONY-321065
  • published13 Jun 2018
  • disclosed13 Jun 2018

Introduced: 13 Jun 2018

CVE-2018-11407  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 symfony to version 3.4.6+dfsg-1ubuntu0.1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream symfony package and not the symfony package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

An issue was discovered in the Ldap component in Symfony 2.8.x before 2.8.37, 3.3.x before 3.3.17, 3.4.x before 3.4.7, and 4.0.x before 4.0.7. It allows remote attackers to bypass authentication by logging in with a "null" password and valid username, which triggers an unauthenticated bind. NOTE: this issue exists because of an incomplete fix for CVE-2016-2403.