Improper Authentication Affecting symfony package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.22% (68th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-SYMFONY-456080
  • published19 Apr 2019
  • disclosed16 May 2019

Introduced: 19 Apr 2019

CVE-2019-10911  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:18.04 symfony.

NVD Description

Note: Versions mentioned in the description apply only to the upstream symfony package and not the symfony package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, a vulnerability would allow an attacker to authenticate as a privileged user on sites with user registration and remember me login functionality enabled. This is related to symfony/security.

CVSS Base Scores

version 3.1