Use After Free Affecting tcpreplay package, versions <4.2.6-1ubuntu0.1~esm2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.25% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-TCPREPLAY-1190270
  • published10 Sept 2020
  • disclosed17 Oct 2018

Introduced: 17 Oct 2018

CVE-2018-18408  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 tcpreplay to version 4.2.6-1ubuntu0.1~esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tcpreplay package and not the tcpreplay package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

A use-after-free was discovered in the tcpbridge binary of Tcpreplay 4.3.0 beta1. The issue gets triggered in the function post_args() at tcpbridge.c, causing a denial of service or possibly unspecified other impact.