Out-of-bounds Read Affecting tcpreplay package, versions <4.2.6-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.27% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-TCPREPLAY-1192321
  • published10 Sept 2020
  • disclosed3 Jul 2018

Introduced: 3 Jul 2018

CVE-2018-13112  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 tcpreplay to version 4.2.6-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tcpreplay package and not the tcpreplay package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

get_l2len in common/get.c in Tcpreplay 4.3.0 beta1 allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via crafted packets, as demonstrated by tcpprep.