Use After Free Affecting tiff package, versions <4.0.9-5ubuntu0.10


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Availability High

    Threat Intelligence

    EPSS 0.05% (15th percentile)
Expand this section
NVD
5.5 medium
Expand this section
SUSE
3.3 low
Expand this section
Red Hat
5.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-UBUNTU1804-TIFF-3319558
  • published 14 Feb 2023
  • disclosed 13 Feb 2023

How to fix?

Upgrade Ubuntu:18.04 tiff to version 4.0.9-5ubuntu0.10 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tiff package and not the tiff package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

LibTIFF 4.4.0 has an out-of-bounds read in tiffcrop in tools/tiffcrop.c:3701, allowing attackers to cause a denial-of-service via a crafted tiff file. For users that compile libtiff from sources, the fix is available with commit afaabc3e.