Information Exposure Affecting twig package, versions <2.4.6-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.41% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-TWIG-342004
  • published23 Mar 2019
  • disclosed23 Mar 2019

Introduced: 23 Mar 2019

CVE-2019-9942  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 twig to version 2.4.6-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream twig package and not the twig package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

A sandbox information disclosure exists in Twig before 1.38.0 and 2.x before 2.7.0 because, under some circumstances, it is possible to call the __toString() method on an object even if not allowed by the security policy in place.

CVSS Base Scores

version 3.1