Use After Free Affecting usbredir package, versions <0.7.1-1ubuntu0.18.04.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.31% (24th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-USBREDIR-1567358
  • published19 Aug 2021
  • disclosed24 Feb 2022

Introduced: 19 Aug 2021

CVE-2021-3700  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 usbredir to version 0.7.1-1ubuntu0.18.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream usbredir package and not the usbredir package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

A use-after-free vulnerability was found in usbredir in versions prior to 0.11.0 in the usbredirparser_serialize() in usbredirparser/usbredirparser.c. This issue occurs when serializing large amounts of buffered write data in the case of a slow or blocked destination.

CVSS Base Scores

version 3.1