Out-of-bounds Write Affecting vim package, versions <2:8.0.1453-1ubuntu1.13+esm8


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.56% (43rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-VIM-6228200
  • published6 Feb 2024
  • disclosed5 Feb 2024

Introduced: 5 Feb 2024

CVE-2024-22667  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 vim to version 2:8.0.1453-1ubuntu1.13+esm8 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vim package and not the vim package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Vim before 9.0.2142 has a stack-based buffer overflow because did_set_langmap in map.c calls sprintf to write to the error buffer that is passed down to the option callback functions.

CVSS Base Scores

version 3.1