Uncontrolled Recursion Affecting vlc package, versions <3.0.8-0ubuntu18.04.1+esm3


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.5% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-VLC-1130231
  • published1 Jun 2025
  • disclosed24 Mar 2020

Introduced: 24 Mar 2020

CVE-2020-6071  (opens in a new tab)
CWE-674  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 vlc to version 3.0.8-0ubuntu18.04.1+esm3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vlc package and not the vlc package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

An exploitable denial-of-service vulnerability exists in the resource record-parsing functionality of Videolabs libmicrodns 0.1.0. When parsing compressed labels in mDNS messages, the compression pointer is followed without checking for recursion, leading to a denial of service. An attacker can send an mDNS message to trigger this vulnerability.

CVSS Base Scores

version 3.1