Incorrect Permission Assignment for Critical Resource Affecting walinuxagent package, versions <2.2.32-0ubuntu1~18.04.2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
5.19% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-WALINUXAGENT-340310
  • published13 Mar 2019
  • disclosed9 Apr 2019

Introduced: 13 Mar 2019

CVE-2019-0804  (opens in a new tab)
CWE-732  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 walinuxagent to version 2.2.32-0ubuntu1~18.04.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream walinuxagent package and not the walinuxagent package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

An information disclosure vulnerability exists in the way Azure WaLinuxAgent creates swap files on resource disks, aka 'Azure Linux Agent Information Disclosure Vulnerability'.