Out-of-Bounds Affecting wavpack package, versions <5.1.0-2ubuntu1.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.02% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-WAVPACK-329638
  • published29 Apr 2018
  • disclosed29 Apr 2018

Introduced: 29 Apr 2018

CVE-2018-10537  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 wavpack to version 5.1.0-2ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream wavpack package and not the wavpack package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

An issue was discovered in WavPack 5.1.0 and earlier. The W64 parser component contains a vulnerability that allows writing to memory because ParseWave64HeaderConfig in wave64.c does not reject multiple format chunks.

CVSS Base Scores

version 3.1