Integer Overflow or Wraparound Affecting whoopsie package, versions <0.2.62ubuntu0.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.44% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-WHOOPSIE-474923
  • published3 Nov 2019
  • disclosed8 Feb 2020

Introduced: 3 Nov 2019

CVE-2019-11484  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 whoopsie to version 0.2.62ubuntu0.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream whoopsie package and not the whoopsie package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Kevin Backhouse discovered an integer overflow in bson_ensure_space, as used in whoopsie.

CVSS Base Scores

version 3.1