Cross-site Scripting (XSS) Affecting xapian-core package, versions <1.4.5-1ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.04% (64th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-XAPIANCORE-263212
  • published11 Jul 2018
  • disclosed2 Jul 2018

Introduced: 2 Jul 2018

CVE-2018-0499  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 xapian-core to version 1.4.5-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream xapian-core package and not the xapian-core package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

A cross-site scripting vulnerability in queryparser/termgenerator_internal.cc in Xapian xapian-core before 1.4.6 exists due to incomplete HTML escaping by Xapian::MSet::snippet().