XML External Entity (XXE) Injection Affecting yaws package, versions <2.0.4+dfsg-2ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.35% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-YAWS-1015793
  • published6 Oct 2020
  • disclosed9 Sept 2020

Introduced: 9 Sep 2020

CVE-2020-24379  (opens in a new tab)
CWE-611  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 yaws to version 2.0.4+dfsg-2ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream yaws package and not the yaws package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

WebDAV implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to XXE injection.

CVSS Base Scores

version 3.1