Out-of-Bounds Affecting zutils package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.67% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-ZUTILS-261492
  • published22 Aug 2018
  • disclosed20 Aug 2018

Introduced: 20 Aug 2018

CVE-2018-1000637  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:18.04 zutils.

NVD Description

Note: Versions mentioned in the description apply only to the upstream zutils package and not the zutils package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

zutils version prior to version 1.8-pre2 contains a Buffer Overflow vulnerability in zcat that can result in Potential denial of service or arbitrary code execution. This attack appear to be exploitable via the victim openning a crafted compressed file. This vulnerability appears to have been fixed in 1.8-pre2.