Out-of-Bounds Affecting elfutils package, versions <0.170-0.5.0ubuntu1.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.35% (72nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1810-ELFUTILS-349358
  • published15 Oct 2018
  • disclosed15 Oct 2018

Introduced: 15 Oct 2018

CVE-2018-18310  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.10 elfutils to version 0.170-0.5.0ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream elfutils package and not the elfutils package as distributed by Ubuntu. See How to fix? for Ubuntu:18.10 relevant fixed versions and status.

An invalid memory address dereference was discovered in dwfl_segment_report_module.c in libdwfl in elfutils through v0.174. The vulnerability allows attackers to cause a denial of service (application crash) with a crafted ELF file, as demonstrated by consider_notes.

CVSS Base Scores

version 3.1