Out-of-bounds Read Affecting file package, versions <1:5.34-2ubuntu0.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.49% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1810-FILE-337650
  • published18 Feb 2019
  • disclosed18 Feb 2019

Introduced: 18 Feb 2019

CVE-2019-8904  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.10 file to version 1:5.34-2ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream file package and not the file package as distributed by Ubuntu. See How to fix? for Ubuntu:18.10 relevant fixed versions and status.

do_bid_note in readelf.c in libmagic.a in file 5.35 has a stack-based buffer over-read, related to file_printf and file_vprintf.