Improper Input Validation Affecting mosquitto package, versions <1.4.15-2ubuntu0.18.10.3


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.44% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1810-MOSQUITTO-284187
  • published5 Jun 2018
  • disclosed5 Jun 2018

Introduced: 5 Jun 2018

CVE-2017-7653  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.10 mosquitto to version 1.4.15-2ubuntu0.18.10.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mosquitto package and not the mosquitto package as distributed by Ubuntu. See How to fix? for Ubuntu:18.10 relevant fixed versions and status.

The Eclipse Mosquitto broker up to version 1.4.15 does not reject strings that are not valid UTF-8. A malicious client could cause other clients that do reject invalid UTF-8 strings to disconnect themselves from the broker by sending a topic string which is not valid UTF-8, and so cause a denial of service for the clients.