Integer Overflow or Wraparound Affecting whoopsie package, versions <0.2.62ubuntu1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.6% (48th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1810-WHOOPSIE-453069
  • published24 Jul 2019
  • disclosed29 Aug 2019

Introduced: 24 Jul 2019

CVE-2019-11476  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.10 whoopsie to version 0.2.62ubuntu1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream whoopsie package and not the whoopsie package as distributed by Ubuntu. See How to fix? for Ubuntu:18.10 relevant fixed versions and status.

An integer overflow in whoopsie before versions 0.2.52.5ubuntu0.1, 0.2.62ubuntu0.1, 0.2.64ubuntu0.1, 0.2.66, results in an out-of-bounds write to a heap allocated buffer when processing large crash dumps. This results in a crash or possible code-execution in the context of the whoopsie process.