Out-of-bounds Read Affecting aspell package, versions <0.60.7~20110707-6ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.26% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1904-ASPELL-533498
  • published14 Oct 2019
  • disclosed14 Oct 2019

Introduced: 14 Oct 2019

CVE-2019-17544  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:19.04 aspell to version 0.60.7~20110707-6ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream aspell package and not the aspell package as distributed by Ubuntu. See How to fix? for Ubuntu:19.04 relevant fixed versions and status.

libaspell.a in GNU Aspell before 0.60.8 has a stack-based buffer over-read in acommon::unescape in common/getdata.cpp via an isolated \ character.

CVSS Base Scores

version 3.1