Buffer Overflow Affecting cups package, versions <2.2.10-4ubuntu2.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.12% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1904-CUPS-533812
  • published17 Aug 2019
  • disclosed27 Oct 2020

Introduced: 17 Aug 2019

CVE-2019-8675  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade Ubuntu:19.04 cups to version 2.2.10-4ubuntu2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cups package and not the cups package as distributed by Ubuntu. See How to fix? for Ubuntu:19.04 relevant fixed versions and status.

A buffer overflow issue was addressed with improved memory handling. This issue is fixed in macOS Mojave 10.14.6, Security Update 2019-004 High Sierra, Security Update 2019-004 Sierra. An attacker in a privileged network position may be able to execute arbitrary code.

CVSS Base Scores

version 3.1