CVE-2019-10691 Affecting dovecot package, versions <1:2.3.4.1-1ubuntu2.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.8% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1904-DOVECOT-533772
  • published19 Apr 2019
  • disclosed24 Apr 2019

Introduced: 19 Apr 2019

CVE-2019-10691  (opens in a new tab)

How to fix?

Upgrade Ubuntu:19.04 dovecot to version 1:2.3.4.1-1ubuntu2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dovecot package and not the dovecot package as distributed by Ubuntu. See How to fix? for Ubuntu:19.04 relevant fixed versions and status.

The JSON encoder in Dovecot before 2.3.5.2 allows attackers to repeatedly crash the authentication service by attempting to authenticate with an invalid UTF-8 sequence as the username.