Improper Input Validation Affecting gnome-desktop3 package, versions <3.32.1-1ubuntu1.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.95% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1904-GNOMEDESKTOP3-533828
  • published22 Apr 2019
  • disclosed22 Apr 2019

Introduced: 22 Apr 2019

CVE-2019-11460  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:19.04 gnome-desktop3 to version 3.32.1-1ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gnome-desktop3 package and not the gnome-desktop3 package as distributed by Ubuntu. See How to fix? for Ubuntu:19.04 relevant fixed versions and status.

An issue was discovered in GNOME gnome-desktop 3.26, 3.28, and 3.30 prior to 3.30.2.2, and 3.32 prior to 3.32.1.1. A compromised thumbnailer may escape the bubblewrap sandbox used to confine thumbnailers by using the TIOCSTI ioctl to push characters into the input buffer of the thumbnailer's controlling terminal, allowing an attacker to escape the sandbox if the thumbnailer has a controlling terminal. This is due to improper filtering of the TIOCSTI ioctl on 64-bit systems, similar to CVE-2019-10063.