Improper Verification of Cryptographic Signature The advisory has been revoked - it doesn't affect any version of package libcrypt-jwt-perl  (opens in a new tab)


Threat Intelligence

EPSS
1.1% (65th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1904-LIBCRYPTJWTPERL-613063
  • published10 Sept 2020
  • disclosed25 Jul 2019

Introduced: 25 Jul 2019

CVE-2019-1010161  (opens in a new tab)
CWE-347  (opens in a new tab)

Amendment

The Ubuntu security team deemed this advisory irrelevant for Ubuntu:19.04.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcrypt-jwt-perl package and not the libcrypt-jwt-perl package as distributed by Ubuntu.

perl-CRYPT-JWT 0.022 and earlier is affected by: Incorrect Access Control. The impact is: bypass authentication. The component is: JWT.pm for JWT security token, line 614 in _decode_jws(). The attack vector is: network connectivity(crafting user-controlled input to bypass authentication). The fixed version is: 0.023.