Out-of-bounds Read Affecting memcached package, versions <1.5.10-0ubuntu1.19.04.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.64% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1904-MEMCACHED-533637
  • published3 Sept 2019
  • disclosed30 Aug 2019

Introduced: 30 Aug 2019

CVE-2019-15026  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:19.04 memcached to version 1.5.10-0ubuntu1.19.04.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream memcached package and not the memcached package as distributed by Ubuntu. See How to fix? for Ubuntu:19.04 relevant fixed versions and status.

memcached 1.5.16, when UNIX sockets are used, has a stack-based buffer over-read in conn_to_str in memcached.c.