Improper Check for Unusual or Exceptional Conditions Affecting mosquitto package, versions <1.5.7-1ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.74% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1904-MOSQUITTO-534256
  • published18 Sept 2019
  • disclosed19 Sept 2019

Introduced: 18 Sep 2019

CVE-2019-11779  (opens in a new tab)
CWE-754  (opens in a new tab)

How to fix?

Upgrade Ubuntu:19.04 mosquitto to version 1.5.7-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mosquitto package and not the mosquitto package as distributed by Ubuntu. See How to fix? for Ubuntu:19.04 relevant fixed versions and status.

In Eclipse Mosquitto 1.5.0 to 1.6.5 inclusive, if a malicious MQTT client sends a SUBSCRIBE packet containing a topic that consists of approximately 65400 or more '/' characters, i.e. the topic hierarchy separator, then a stack overflow will occur.

CVSS Base Scores

version 3.1