Allocation of Resources Without Limits or Throttling The advisory has been revoked - it doesn't affect any version of package tika  (opens in a new tab)


Threat Intelligence

EPSS
2.46% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1904-TIKA-530295
  • published2 Aug 2019
  • disclosed2 Aug 2019

Introduced: 2 Aug 2019

CVE-2019-10094  (opens in a new tab)
CWE-770  (opens in a new tab)

Amendment

The Ubuntu security team deemed this advisory irrelevant for Ubuntu:19.04.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tika package and not the tika package as distributed by Ubuntu.

A carefully crafted package/compressed file that, when unzipped/uncompressed yields the same file (a quine), causes a StackOverflowError in Apache Tika's RecursiveParserWrapper in versions 1.7-1.21. Apache Tika users should upgrade to 1.22 or later.