Out-of-Bounds Affecting freetds package, versions <1.1.6-1ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.78% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1910-FREETDS-576780
  • published17 Oct 2019
  • disclosed31 Oct 2019

Introduced: 17 Oct 2019

CVE-2019-13508  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:19.10 freetds to version 1.1.6-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream freetds package and not the freetds package as distributed by Ubuntu. See How to fix? for Ubuntu:19.10 relevant fixed versions and status.

FreeTDS through 1.1.11 has a Buffer Overflow.

CVSS Base Scores

version 3.1