Improper Input Validation Affecting libarchive package, versions <3.4.0-1ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.25% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1910-LIBARCHIVE-577971
  • published21 Feb 2020
  • disclosed20 Feb 2020

Introduced: 20 Feb 2020

CVE-2020-9308  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:19.10 libarchive to version 3.4.0-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libarchive package and not the libarchive package as distributed by Ubuntu. See How to fix? for Ubuntu:19.10 relevant fixed versions and status.

archive_read_support_format_rar5.c in libarchive before 3.4.2 attempts to unpack a RAR5 file with an invalid or corrupted header (such as a header size of zero), leading to a SIGSEGV or possibly unspecified other impact.

CVSS Base Scores

version 3.1