Allocation of Resources Without Limits or Throttling The advisory has been revoked - it doesn't affect any version of package node-lodash  (opens in a new tab)


Threat Intelligence

EPSS
3.04% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1910-NODELODASH-644822
  • published24 Jul 2019
  • disclosed17 Jul 2019

Introduced: 17 Jul 2019

CVE-2019-1010266  (opens in a new tab)
CWE-770  (opens in a new tab)

Amendment

The Ubuntu security team deemed this advisory irrelevant for Ubuntu:19.10.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-lodash package and not the node-lodash package as distributed by Ubuntu.

lodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.17.11.