Allocation of Resources Without Limits or Throttling Affecting tika package, versions <1.22-1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.46% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1910-TIKA-583131
  • published2 Aug 2019
  • disclosed2 Aug 2019

Introduced: 2 Aug 2019

CVE-2019-10094  (opens in a new tab)
CWE-770  (opens in a new tab)

How to fix?

Upgrade Ubuntu:19.10 tika to version 1.22-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tika package and not the tika package as distributed by Ubuntu. See How to fix? for Ubuntu:19.10 relevant fixed versions and status.

A carefully crafted package/compressed file that, when unzipped/uncompressed yields the same file (a quine), causes a StackOverflowError in Apache Tika's RecursiveParserWrapper in versions 1.7-1.21. Apache Tika users should upgrade to 1.22 or later.