Use After Free Affecting vim package, versions <2:8.1.0875-5ubuntu2.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.89% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1910-VIM-581647
  • published30 Dec 2019
  • disclosed30 Dec 2019

Introduced: 30 Dec 2019

CVE-2019-20079  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Ubuntu:19.10 vim to version 2:8.1.0875-5ubuntu2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vim package and not the vim package as distributed by Ubuntu. See How to fix? for Ubuntu:19.10 relevant fixed versions and status.

The autocmd feature in window.c in Vim before 8.1.2136 accesses freed memory.

CVSS Base Scores

version 3.1