Information Exposure Affecting aptdaemon package, versions <1.1.1+bzr982-0ubuntu32.3


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.34% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-APTDAEMON-1049100
  • published9 Dec 2020
  • disclosed9 Dec 2020

Introduced: 9 Dec 2020

CVE-2020-16128  (opens in a new tab)
CWE-209  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 aptdaemon to version 1.1.1+bzr982-0ubuntu32.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream aptdaemon package and not the aptdaemon package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

The aptdaemon DBus interface disclosed file existence disclosure by setting Terminal/DebconfSocket properties, aka GHSL-2020-192 and GHSL-2020-196. This affected versions prior to 1.1.1+bzr982-0ubuntu34.1, 1.1.1+bzr982-0ubuntu32.3, 1.1.1+bzr982-0ubuntu19.5, 1.1.1+bzr982-0ubuntu14.5.

CVSS Base Scores

version 3.1