Out-of-Bounds Affecting frr package, versions <7.2.1-1ubuntu0.2+esm2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.01% (59th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-FRR-2415442
  • published4 Jun 2024
  • disclosed3 Mar 2022

Introduced: 3 Mar 2022

CVE-2022-26129  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 frr to version 7.2.1-1ubuntu0.2+esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream frr package and not the frr package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

Buffer overflow vulnerabilities exist in FRRouting through 8.1.0 due to wrong checks on the subtlv length in the functions, parse_hello_subtlv, parse_ihu_subtlv, and parse_update_subtlv in babeld/message.c.

CVSS Base Scores

version 3.1