CVE-2023-31490 Affecting frr package, versions <7.2.1-1ubuntu0.2+esm2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.15% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-FRR-5511025
  • published4 Jun 2024
  • disclosed9 May 2023

Introduced: 9 May 2023

CVE-2023-31490  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 frr to version 7.2.1-1ubuntu0.2+esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream frr package and not the frr package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

An issue found in Frrouting bgpd v.8.4.2 allows a remote attacker to cause a denial of service via the bgp_attr_psid_sub() function.

CVSS Base Scores

version 3.1