CVE-2023-46753 Affecting frr package, versions <7.2.1-1ubuntu0.2+esm2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.94% (61st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-FRR-6036961
  • published4 Jun 2024
  • disclosed26 Oct 2023

Introduced: 26 Oct 2023

CVE-2023-46753  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 frr to version 7.2.1-1ubuntu0.2+esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream frr package and not the frr package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

An issue was discovered in FRRouting FRR through 9.0.1. A crash can occur for a crafted BGP UPDATE message without mandatory attributes, e.g., one with only an unknown transit attribute.

CVSS Base Scores

version 3.1