CVE-2024-31948 Affecting frr package, versions <7.2.1-1ubuntu0.2+esm2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.83% (53rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-FRR-6591203
  • published7 Jun 2024
  • disclosed7 Apr 2024

Introduced: 7 Apr 2024

CVE-2024-31948  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 frr to version 7.2.1-1ubuntu0.2+esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream frr package and not the frr package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

In FRRouting (FRR) through 9.1, an attacker using a malformed Prefix SID attribute in a BGP UPDATE packet can cause the bgpd daemon to crash.

CVSS Base Scores

version 3.1