Information Exposure Affecting gcc-10 package, versions <10.2.0-5ubuntu1~20.04


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.51% (43rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-GCC10-1245008
  • published12 Jun 2020
  • disclosed8 Jun 2020

Introduced: 8 Jun 2020

CVE-2020-13844  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 gcc-10 to version 10.2.0-5ubuntu1~20.04 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gcc-10 package and not the gcc-10 package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

Arm Armv8-A core implementations utilizing speculative execution past unconditional changes in control flow may allow unauthorized disclosure of information to an attacker with local user access via a side-channel analysis, aka "straight-line speculation."

CVSS Base Scores

version 3.1