Out-of-bounds Read Affecting gerbv package, versions <2.7.0-1ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.29% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-GERBV-2404083
  • published16 Feb 2022
  • disclosed14 Apr 2022

Introduced: 16 Feb 2022

CVE-2021-40400  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 gerbv to version 2.7.0-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gerbv package and not the gerbv package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

An out-of-bounds read vulnerability exists in the RS-274X aperture macro outline primitive functionality of Gerbv 2.7.0 and dev (commit b5f1eacd) and the forked version of Gerbv (commit d7f42a9a). A specially-crafted Gerber file can lead to information disclosure. An attacker can provide a malicious file to trigger this vulnerability.

CVSS Base Scores

version 3.1