Server-Side Request Forgery (SSRF) Affecting glance package, versions <2:20.2.0-0ubuntu1.2+esm2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.28% (21st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-GLANCE-15893340
  • published16 Apr 2026
  • disclosed31 Mar 2026

Introduced: 31 Mar 2026

CVE-2026-34881  (opens in a new tab)
CWE-918  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 glance to version 2:20.2.0-0ubuntu1.2+esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream glance package and not the glance package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

OpenStack Glance before 29.1.1, 30.x before 30.1.1, and 31.0.0 is affected by Server-Side Request Forgery (SSRF). By use of HTTP redirects, an authenticated user can bypass URL validation checks and redirect to internal services. Only glance image import functionality is affected. In particular, the web-download and glance-download import methods are subject to this vulnerability, as is the optional (not enabled by default) ovf_process image import plugin.

CVSS Base Scores

version 3.1