Improper Input Validation Affecting gradle package, versions *


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.89% (60th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-GRADLE-583322
  • published24 Sept 2019
  • disclosed16 Sept 2019

Introduced: 16 Sep 2019

CVE-2019-16370  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:20.04 gradle.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gradle package and not the gradle package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

The PGP signing plugin in Gradle before 6.0 relies on the SHA-1 algorithm, which might allow an attacker to replace an artifact with a different one that has the same SHA-1 message digest, a related issue to CVE-2005-4900.

CVSS Base Scores

version 3.1