CVE-2025-47219 Affecting gst-plugins-good1.0 package, versions <1.16.3-0ubuntu1.3+esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.67% (51st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-GSTPLUGINSGOOD10-11543962
  • published22 Mar 2026
  • disclosed7 Aug 2025

Introduced: 7 Aug 2025

CVE-2025-47219  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 gst-plugins-good1.0 to version 1.16.3-0ubuntu1.3+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gst-plugins-good1.0 package and not the gst-plugins-good1.0 package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

In GStreamer through 1.26.1, the isomp4 plugin's qtdemux_parse_trak function may read past the end of a heap buffer while parsing an MP4 file, possibly leading to information disclosure.

CVSS Base Scores

version 3.1