Out-of-bounds Write Affecting hdf5 package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.28% (20th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-HDF5-9576133
  • published17 Jan 2026
  • disclosed28 Mar 2025

Introduced: 28 Mar 2025

CVE-2025-2923  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:20.04 hdf5.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hdf5 package and not the hdf5 package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

A vulnerability, which was classified as problematic, has been found in HDF5 up to 1.14.6. Affected by this issue is the function H5F_addr_encode_len of the file src/H5Fint.c. The manipulation of the argument pp leads to heap-based buffer overflow. Attacking locally is a requirement. The exploit has been disclosed to the public and may be used.

CVSS Base Scores

version 3.1