Directory Traversal Affecting hsqldb1.8.0 package, versions <1.8.0.10+dfsg-10ubuntu0.20.04.1~esm1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
64.64% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-HSQLDB180-5725755
  • published9 Sept 2026
  • disclosed10 Jul 2023

Introduced: 10 Jul 2023

CVE-2023-1183  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 hsqldb1.8.0 to version 1.8.0.10+dfsg-10ubuntu0.20.04.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hsqldb1.8.0 package and not the hsqldb1.8.0 package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

A flaw was found in the Libreoffice package. An attacker can craft an odb containing a "database/script" file with a SCRIPT command where the contents of the file could be written to a new file whose location was determined by the attacker.

CVSS Base Scores

version 3.1