Out-of-bounds Write Affecting indent package, versions <2.2.12-1ubuntu0.20.04.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.44% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-INDENT-5840721
  • published14 Aug 2023
  • disclosed14 Aug 2023

Introduced: 14 Aug 2023

CVE-2023-40305  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 indent to version 2.2.12-1ubuntu0.20.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream indent package and not the indent package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

GNU indent 2.2.13 has a heap-based buffer overflow in search_brace in indent.c via a crafted file.

CVSS Base Scores

version 3.1