CVE-2020-35605 Affecting kitty package, versions <0.15.0-1ubuntu0.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.76% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-KITTY-1131256
  • published7 Oct 2022
  • disclosed21 Dec 2020

Introduced: 21 Dec 2020

CVE-2020-35605  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 kitty to version 0.15.0-1ubuntu0.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kitty package and not the kitty package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

The Graphics Protocol feature in graphics.c in kitty before 0.19.3 allows remote attackers to execute arbitrary code because a filename containing special characters can be included in an error message.

CVSS Base Scores

version 3.1