Improper Verification of Cryptographic Signature Affecting lasso package, versions <2.6.0-7ubuntu1.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.38% (72nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-LASSO-1298609
  • published2 Jun 2021
  • disclosed4 Jun 2021

Introduced: 2 Jun 2021

CVE-2021-28091  (opens in a new tab)
CWE-347  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 lasso to version 2.6.0-7ubuntu1.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lasso package and not the lasso package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

Lasso all versions prior to 2.7.0 has improper verification of a cryptographic signature.

CVSS Base Scores

version 3.1