Out-of-bounds Write The advisory has been revoked - it doesn't affect any version of package libgcrypt20  (opens in a new tab)


Threat Intelligence

EPSS
1.06% (61st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-LIBGCRYPT20-1066027
  • published30 Jan 2021
  • disclosed29 Jan 2021

Introduced: 29 Jan 2021

CVE-2021-3345  (opens in a new tab)
CWE-787  (opens in a new tab)

Amendment

The Ubuntu security team deemed this advisory irrelevant for Ubuntu:20.04.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libgcrypt20 package and not the libgcrypt20 package as distributed by Ubuntu.

_gcry_md_block_write in cipher/hash-common.c in Libgcrypt version 1.9.0 has a heap-based buffer overflow when the digest final function sets a large count value. It is recommended to upgrade to 1.9.1 or later.